Jump to content

FS Commander Registration problems

Recommended Posts

I've sent a message to H. Volker but have not received a reply (it has been less than a day).



Win 10

Registered User of FS Commander 8.5 Build 200409


Purchased FS Commander 10 for FSX from FlightSim.com Store (Aerosoft version)


I have tried EVERY possible combination of names to register and always am told there is an error. I double checked the email field and am using the one to which the purchase confirmation, containing the Key Code, was sent. I've carefully followed the instructions in the registration failure PDF I received with the file download.


The FlightSim store e-mail tells me the key code, which I copy into the proper field on the FS Commander registration screen.


BUT - AFTER I enter that into the Key Code Field (and VERIFY it is accurate and complete) it appears changed after I press the Register button. The first THREE (FSC) characters are DROPPED from the left most box and the last three character are appended to the end of the key in the right most box. I am unable to modify the contents of the boxes after they are erroneously changed.


I have verified the E:\Program Files\FS Commander V10 folder is NOT read only. I created a .txt file there and can edit that file with no problem.


I downloaded the ASD-2068-fsc10-fsx-fs9.zip file from the FlightSim.com store website by clicking on the download link in the e-mail they sent me.


FS Commander V10 works well on my system but is an unregistered copy and times out after 30-minutes as well as does not allow me to save flight plans.


I HAVE downloaded the V10 zip a 2nd time. I then Uninstalled FSC V10 and reinstalled it (AS ADMINISTRATOR!). The DB manager works perfectly.


There was NO registration.fsc file in the FS Commander V10 folder.


The V8.5 version still works OK so there is no rush - but I really want to finish this upgrade, which I had to pay for.


I have been a professional computer systems programmer since 1969, a Windows user and system person since before it became public, and an MS Flight Sim use since the very first Meigs Field edition.


I have installed many hundreds of add ons to FSX with seldom a problem.


Any help is appreciated.

Edited by tacomasailor
i7-9700K / 32GB DDR4 memory / RTX 3060 Ti with 8GB /Flight Sim on SSD and Win10 on separate SSD / 375 MegaBit / Second internet connection / HP Reverb G2
Link to comment
Share on other sites

I received a reply from V. Heine which says

"Your two registration screenshots indicate that you are not using an Aerosoft-made installation. (Provided by SM)

A FlightSim Commander product from Aerosoft does not use this type of registration.

The Aerosoft FlightSim Commander product is always, without exception, registered "during installation".


Please contact the Aerosoft support team with your problem. (https://www.aerosoft.com/en/contact)"


BUT the email I received from store.Flightsim.com to confirm my purchase and to give me the link to the download says:

Hi Jerald,


We have finished processing your order.



Product Expires Download

Aerosoft - Flight Sim Commander 10 Never ASD-2068-fsc10-fsx-fs9.zip

A2A Simulations - Accu-Sim C182 Skylane for FSX Never ATS-165-Accu-Sim_skylane_fsx.zip

[Order #xxxxx] (July 27, 2019)

Product Quantity Price

Aerosoft - Flight Sim Commander 10

ASD-2068 - 1 domain per key




You can manage your keys from My Account


1 $33.99


It appears the store.FlightSim.com link is for a Aerosoft version of FS Commander V10 but something is wrong in the download.


I have deleted every reference to the download and the install of FS Commander. I then downloaded it a THIRD time with the same result.


What to to now?

i7-9700K / 32GB DDR4 memory / RTX 3060 Ti with 8GB /Flight Sim on SSD and Win10 on separate SSD / 375 MegaBit / Second internet connection / HP Reverb G2
Link to comment
Share on other sites

Everything is working as is should! No idea Why?


Deleted all files and folders, made sure there were no registery entries, used Windows Uninstall to verify everything was deleted. Then used IOBit Uninstaller to further verify there was NO remnant of FS Commander 10 anywhere on the system.


Downloaded FS Commander V10 from the store.FlightSim.com link and ran the setup/installer as ADMINISTRATOR (same as previous three install attempts). This time the Aerosoft Installer (had not seen that one before) asked for the license key, which I provided from the flightsim store e-mail.


Registration was completed and FS Commander V10 is now running perfectly on my system.


I think the problem was that I had previously downloaded the FREE 30-minute trial copy of FS Commander V10 from the FSC website and had used it for a couple days in trial mode. I did a Win Remove Program on it before the first install of the purchased copy. But, I bet that uninstall left some remnants that caused a bad install of the purchased version.


Oh Well - it is all good now!

i7-9700K / 32GB DDR4 memory / RTX 3060 Ti with 8GB /Flight Sim on SSD and Win10 on separate SSD / 375 MegaBit / Second internet connection / HP Reverb G2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...