Jump to content

No response to my eager clicking.


Recommended Posts

Hi all,

New here but an oldie to FSX.

Had it for a long time, many years indeed.

It's the DVD edition..not Steam in any way.


Been running it on my W10 GTX1070 machine for ages..All ok and great. Latest drivers etc etc. installed too.


A couple of days ago I clicked on the FSX icon and the little blue loading circle spun about for a second or two then..nothing!

No error messages..Just nothing happened.

Clicking again..same result.


Checked file location...All seems to be where it always was and the file size the same


Tried executing the executable (!) from the FSX folder..Guess what..Same thing. Nothing happens.


So. Maybe the latest W10 update?

Maybe something I recently downloaded?


But maybe someone here has experienced this happening?

I thought it worth asking before I (shudder) reinstall FSX.


I guess I could drop back W10 to the earlier version or restore the system back somewhat. But before all that drastic stuff..Any one with any clues or answers?


Link to comment
Share on other sites

Close fsx

rename the fsx.cfg

file to fsx_old.cfg

shut the pc down (full shutdown, not sleep mode),

boot the pc

start fsx.


Thanks for your hint..The Config file resides where?

I will look later but..just in case it's hidden away in some strange place?

I'm betting..well hoping your valuable assistance is the answer.

Just want to be sure I get the right file!


Link to comment
Share on other sites

No need to go back to earlier Win 10 versions, FSX runs fine on the latest.




Thanks. That's good to know that the latest W10 is still ok fpr FSX.


Found the config files in User/Roaming etc etc. Renamed..But FSX still behaving the same.

Sorry about these mailing overlaps. It appears that being a NEW member means a wait between posts being posted !


But anyway..Any other answers/ clues/ things to further try?


Link to comment
Share on other sites

A possible cause is either a corrupted logbook or corrupted saved flight - try the following options....


Option 1 - Disable the logbook.


1. Go to C:\Documents\Flight Simulator X Files.

2. Rename the Logbook.BIN file to Logbook.OLD.

3. Start FSX.


If FSX loads, carryout a quick test flight and then exit - this will force a new logbook.BIN to be created. Restart FSX to see if the issue remains resolved.


NOTE: Using this method does mean that you will lose any flight hours already logged. However, if this action resolves the issue you could then attempt to retrieve info from the old logbook file as follows:


(OR you could even try using this procedure before carrying out method 1 if you wish. Simply skip steps 2 and 3):


1. Download and install the following file from the file library here at flightsim.com - fsxlog11.zip - this is a very easy to use logbook recovery/backup tool. The install instructions are contained in the readme file provided.

2. Rename the current (i.e. new) logbook.BIN to logbook.NEW.

3. Rename the old (i.e. corrupted) logbook.OLD to logbook.BIN.

4. Run the fsxlog11 tool. Once the tool is open click on the Analyze button. This will go through the entries and list any errors.

5. Click on the Recover button. The tool will attempt to recover the logbook back to the last known good state.


Method 2 - Attempt to revert back to the default FSX flight by editing the FSX.cfg file.


1. Open the FSX.cfg file and locate the following entry


SITUATION=C:\Users\Brian\Documents\Flight Simulator X Files\F35A Current


You will find the entry under the [uSERINTERFACE] section. The items highlighted in RED will be different in your entry as they will be specific entries relating to your FSX installation.


2. Change the statement so that is simply reads SITUATION=


3. Save and Close the fsx.cfg file.


4. Test FSX. If successful it will load the default FSX flight - i.e the microlight over Friday Harbour.


NOTE: IME there is no need to shutdown/restart the PC after making changes to the fsx.cfg file as stated by il88pp at post #3.


My final comments are WRT possible problems caused by Win 10 updates. I updated to Win 10 about 6 months after it was released and have been using FSX on two Win 10 based rigs since then with no issues.


It is worth noting, however, as you are using Win 10, that the shutdown process of Win 10 works differently from earlier versions of Windows WRT what happens when you shutdown or restart the PC.


In earlier versions of Windows (i.e. Win XP, Vista, 7 and earlier versions of 8) a shutdown will FULLY clear what is called the Windows kernel memory (resulting in a longer boot up at next power on) whilst a restart will only PARTIALLY clear the kernel memory (allowing a quick reboot). In Win 10 (and some versions of Win 8.1 where the process was introduced) this has been reversed with a shutdown now acting like a restart and a restart acting like a shutdown - see this LINK for more info. Therefore, in Win 10 after a windows update, a restart (and not the traditional shutdown/reboot) is required to allow the updates to be fully installed and all appropriate sys files/registry entries to update correctly.


I have seen instances of this causing issues with FSX (and other software), especially where people leave their PCs on constantly or only use the 'shutdown' or, following an update, the 'update and shutdown' option that is displayed. IME the 'update/shutdown' option does not always allow updates to install fully and a 'restart' is still required. It can also be a source of 'failed' update entries in the update history listing and/or errors found in Event logs files.




Link to comment
Share on other sites

Thanks a lot for that, longbreak754 and to all who have given hints.


I shall go through longbreak's list during the weekend when I can concentrate !


So far and following the other hints, I'm still at stage 1.

But the above with longbreak 754's possible solution looks very interesting.


Oh yes, I noticed I have config files from FSXse also with the FSX config. I renamed that one as well.

I do use FlyInside, a VR hook for my CV1 goggles.

I know that Flyinside also has config files. Not sure to rename those.

But The FSX program I don't think even gets that far. All stops in less than two seconds.

Might first wait until after this weekend?


Great support of which I do appreciate.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...