Jump to content

A2A simulations website down?

Recommended Posts

Hi all,


I know that A2A has had some server issues recently. I have been unable to get onto their site for the past several days. Anybody know what is going on?








Hello everyone,

as many will have noticed the A2A Simulations domain is down. We are continuing to work with our hosts engineers to fix the on going issue. When we have an ETA for the repairs we will let you know. Sorry for the inconvenience this is causing some customers.

Once we are live and stable again we will be posting a company update with projects we can now finally mention and show. We cannot wait for this and the downtime has come at such an unfortunate time just as we want to show you things!

We will also be having a,

"We are alive and no we are not dead and yes we do use one of the largest hosting companies on the planet and omg downtime is the worse in the world sale"

Once we are live and stable to accompany the company update on the A2A Store (so yay sales!).

And lastly once live we will be very close to pushing out several updates for existing products including the Accu-sim Bonanza simulation, Accu-sim P-40 P3Dv4 simulation, Accu-sim Spitfire simulation P3Dv4 etc etc, more news on those another day.

Thanks for bearing with us, you guys and girls are awesome.

And as always, though the domain is down the A2A Community discord is up for chat and getting some group flights going, the Facebook is up, the twitter is up, the tumblr is up, the Instagram is up etc so you can always get your A2A hits via other channels.

A2A Simulations Community discord; https://discord.gg/ZJDfERf

A2A Simulations Instagram;



A2A Simulations Twitter;

A2A Simulations Tumblr; https://a2asimulations.tumblr.com/

Link to comment
Share on other sites

I just tried it on Win7 x64 using Chrome browser and they're online now: https://a2asimulations.com/

Tim Wright "The older I get, the better I was..."

Xbox Series X, Asus Prime H510M-K, Intel Core i5-11400F 4.40GHz, 16Gb DDR4 3200, 2TB WD Black NVME SSD, 1TB Samsung SATA SSD

NVidia RTX3060 Ti 8Gb, Logitech Yoke System, CH Pro Pedals, Acer K272HL 27", Windows 11 Home x64

Link to comment
Share on other sites

Thanks for the responses everyone. I am still unable to access their site from Western Pennsylvania. I can't get to it on my iPad or PC. I even tried on my iPhone on a cellular network. So I guess the problem is probably not on my end.


I will keep trying.




Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...