Jump to content

Saitek yoke not recognized ingame (but in Windows)

Recommended Posts

Hello there,


I've been browsing this (and other forums) for my problem, but I'm not getting anywhere. Maybe one of you guys can help me.


System specs:

  • OS: Windows 10 Pro (1803) with all updates installed,
  • CPU: i5-4960
  • RAM: 16 GB
  • GPU: GTX 1080



I bought some Saitek gear a couple months ago and used it with the Steam edition of FSX perfectly fine for the longest time since. After not having used it for ~2 weeks, it completely stopped working a while ago. It's not recognized anymore by the game (doesn't show up in the controller options, https://imgur.com/1Grk2vn https://imgur.com/fqfOv6J ). I also recently purchased X-Plane, but that one has the same issue. What's really confusing about this is that the controller shows up in the Windows settings ( https://imgur.com/JdcKZWJ ) and I can even get to the dialog, where I can see all the buttons and axes light up when I press/move the controller ( https://imgur.com/fTqnzZl ).

The multi panel still works perfectly fine


What I have done so far:

  • removed all drivers through the device manager (both input devices and USB hubs)
  • tried various USB ports on my computer
  • tried unplugging other USB devices
  • checked energy saving settings (both manually, and using some tool)
  • reinstalled logitech software
  • reinstalled game specific plugins
  • tried with a fresh installation of x-plane
  • verified integrity of games on steam


Those were all the suggestions I found online. As mentioned, I am particularly confused about the fact that it shows up and works perfectly fine in the Windows settings, but not in game. Has anyone run into similar issues or any other idea what this might be caused by?


Thanks a lot in advance!




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...