Jump to content

"Flight Simulator X has stopped working"


Recommended Posts

Hello everyone.


Well, first I want to tell you about my FSX experience and the "mysterious reason for my crash".


I have bought FSX Steam Edition five or four mounths ago, and I had no trouble.But three days ago always when I start Flight Simulator X it crashes. But it had a evolution, what do I mean?


First when I started it, it crashes and then "Fatal error has ocurried", then, I was looking the way to fix it, on youtube, forums, etc. And no solution has worked for me. But one day later, the error has changed to "Flight Simulator X has stopped working", and I have again looked for fixes. (No tutorials, vidios, etc has worked for me). Well, so I said, I got to re-install it, right?


Four hours re-installing the game, and...Nothing, Its still crashing, I dont know what to do. I dont know if I got to download a Ilegal copy or what. So, please, Does somebody know what should I do?


I will show you some information:


My system: (Spanish)


Procesador: Intel® Core™ i5-4440 CPU @ 3.10GHz, 3101 Mhz, 4 procesadores principales, 4 procesadores lógicos

Nombre del SO: Microsoft Windows 10 Home Single Language

Memoria física instalada (RAM): 8,00 GB

Configuración regional: Argentina

Card: Amd rodeon R7-200 series 4gb ddr5

Directx: Directx 12 (Last version)

FSX: Steam Edition (Not a Ilegal copy)


Tutorials I have tried:


-Installing msxml (C:\Program Files (x86)\Steam\steamapps\common\FSX\Installers) But it says I already got it.

-Changing propiedates.

-Re-Installing game.

-Deleting mods and add-ons.(I have payware add-ons)

-Replacing "UIAutomationCore.dll"


But no one of that has worked to me.


Thank you for your attention.

Link to comment
Share on other sites

Oops, I forgot this...


Nombre de la aplicación con errores: fsx.exe, versión: 10.0.62615.0, marca de tiempo: 0x559f9a9a

Nombre del módulo con errores: ntdll.dll, versión: 10.0.14393.1715, marca de tiempo: 0x59b0d8f3

Código de excepción: 0xc0000005

Desplazamiento de errores: 0x00045cd8

Identificador del proceso con errores: 0x2b14

Hora de inicio de la aplicación con errores: 0x01d35bd20915b78b

Ruta de acceso de la aplicación con errores: C:\Program Files (x86)\Steam\steamapps\common\FSX\fsx.exe

Ruta de acceso del módulo con errores: C:\WINDOWS\SYSTEM32\ntdll.dll

Identificador del informe: 1127ab89-89fd-4568-8a1f-8433b91343e9

Nombre completo del paquete con errores:

Identificador de aplicación relativa del paquete con errores:

Link to comment
Share on other sites

We need to know what the "faulting module" is to be able to give advice.


Control Panel-> Administrative Tools-> Event Viewer, select Custom Views-> Administrative Events.

One of the listed events will be for your CTD. The "Faulting Module" should point to the problem area.


Tell us what the Faulting Module is! That will point us in the direction of the proper error, aiding in troubleshooting.





General Tab:

Faulting application name: fsx.exe, version: 10.0.61637.0, time stamp: 0x46fadb14

Faulting module name: This is what we need to Know!

Exception code: 0xc0000005

Fault offset: 0x0000ee3a

Faulting process id: 0x748

Faulting application start time: 0x01ce0253dc4b69d4

Faulting application path: R:\FSX\fsx.exe

Faulting module path: R:\FSX\window.dll

Report Id: 9caf77b4-6e50-11e2-8570-3085a99825d1


If there is not one listed:

Faulting module name: unknown, version:, time stamp: 0x00000000,

you will need to do as previously noted



No Faulting Module? ->

Remove all of the add-ons, and test the sim. If it works OK, then reinstall them one at a time and test.

Be sure to test each thoroughly before moving on to the next

Still thinking about a new flightsim only computer!  ✈️

Link to comment
Share on other sites

I've found that quite often, if you don't land at an airport before exiting the simulator completely, IE, right after a crash, or just cruising along in the air, it will crash like this.

Just open up your FSX.CFG with NotePad (included with Windoze), never EVER use a word processor. Look through it for the heading [uSERINTERFACE]. Under that is a line that starts out SITUATION= . Once you find that, simply delete everything after the equals sign ( = ). Save the file off, and try starting the sim.

Another problem that can occur is the corruption of the Logbook file. There are a number of files in the library here to fix corrupted logbooks. Just DL, install, and follow the instructions on repairing a logbook.bin file.


I don't know if either of those two situations are applicable, but worth a look, mayhap :)




Had a thought...then there was the smell of something burning, and sparks, and then a big fire, and then the lights went out! I guess I better not do that again!

Sgt, USMC, 10 years proud service, Inactive reserve now :D

Link to comment
Share on other sites

Most crashes caused by the ntdll.dll seem to be caused by AI traffic. I am not using any payware traffic but if my slider is a bit too high I will get that crash occasionally. That's where I would start in troubleshooting this error.

Still thinking about a new flightsim only computer!  ✈️

Link to comment
Share on other sites

The ntdll.dll file is not a native FSX file but a 32 bit OS system file. Many FSX related issues that seem to be caused by it may be a 'false' report not directly related to actual reason why the file has become corrupted and caused the issue. Like many other system related .dll files they are used by many apps and a failure caused by corruption by one app may not become apparent until another app tries to use the file. The corruption can by caused by many things, including a failed windows update, failed/incorrect installation of an app, incorrectly/unexpected closing an app etc.......


I suggest you run the System File Check (SFC) utility. SFC can be used to scan the integrity of all protected operating system files and replaces incorrect, corrupted, changed, or damaged versions with the correct versions where possible.


NOTE - you may have to run the utility with Admin rights........


To run SFC go to start > run, type CMD and click OK.

The resulting window should show an entry similar to this - C:\Users\youracctname>

Type cd\ and hit enter - this will take you back to the C:\ prompt

To start SFC type one of the command lines listed below and hit enter


If you just want to verify only type sfc /verifyonly (note the space between sfc and "/") - using this option no changes will be made if errors are found and when it has finished it will display a list of any errors found.


If you want to find and repair errors type sfc /scannow (again note the space between sfc and "/") - using this option the program will automatically attempt to repair any errors found. At the end of the process one of the following messages will be displayed:


Windows Resource Protection did not find any integrity violations.

Windows Resource Protection found corrupt files and repaired them.

Windows Resource Protection found corrupt files but was unable to fix some (or all) of them.


Note: The process can take a long while to run and may seem to have stalled - it hasn't just wait until you get the one of the messages stated above. If is also worth noting that you may have to run the utility several times to fix all the problems. If the first run found multiple problems and states that it was unable to fix some of them, reboot the PC and run SFC again. This is because one or more of the unrepaired problem file(s) probably relies on one of the now fixed files to be running correctly to run itself.




Link to comment
Share on other sites

  • 6 months later...

Hello people,


Well, i also have the same issue: my FSX will crash when I'm midair. I was doing a flight from Dubai to Geneva, when suddenly, FSX says Not Responding, and moments later, a message pops up, telling that a fatal error has occurred.


I've been having this issue for a while. Initially I thought it was maybe because the graphic drivers were outdated. I updated and tested the sim, but, to no avail.


My system specs are as follows:


OS Name Microsoft Windows 10 Home Single Language

System Model Inspiron 5559

System Type x64-based PC

Processor Intel® Core™ i5-6200U CPU @ 2.30GHz, 2400 Mhz, 2 Core(s), 4 Logical Processor(s)

Installed Physical Memory (RAM) 8.00 GB

Display Adapters: AMD Radeon R5M335, Intel® HD Graphics 520


The faulting module tells the following:

Faulting application name: fsx.exe, version: 10.0.61637.0, time stamp: 0x46fadb14

Faulting module name: unknown, version:, time stamp: 0x00000000

Exception code: 0xc0000005

Fault offset: 0x8801f900

Faulting process id: 0x8bc

Faulting application start time: 0x01d401752c9b043c

Faulting application path: C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\fsx.exe

Faulting module path: unknown

Report Id: 80c7b2ea-5e66-4fc8-8517-ac84fba1e0a3

Faulting package full name:

Faulting package-relative application ID:


My FSX System has no installed AI Traffic (just the default ones). I've also downloaded SP1 and the Acceleration Pack. I do have FlyTampa Dubai.


I'd really appreciate it if any one could help resolve this issue once and for all.




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...