Jump to content

FSX activated, will not load past splash screen.


Recommended Posts

Ok, it's time I ask for help.


I've been a Flight Simmer for many years now (fs200 thru FSX). I've installed and uninstalled FS many times over the years without problems, but this time is different . . .


About two weeks ago, my computer started doing crazy things. Some programs worked fine but others didn't. Some wouldn't start at all. etc. Took my computer to my repairman (professional), after looking it over for a day or so he tells me my power supply was failing and sending out random voltage spikes which were obviously not doing my computer any good. It took him several days, but he did finally get my operating system reinstalled and rumnning properly (XP 32 bit). Apparently, my XP disc just wouldn't work and he ended up installing it from one of his own oem discs. he warned me that while everything was operating again, I would probably have to reload some software. He was correct. Some software worked properly without having to do anything. Some software had to be reloaded, but then ran perfectly fine. The big problem is, of course, FSX. It wouldn't do anything at the outset. BTW, FSX is loaded on a separate, internally installed 1 terabyte harddrive (D:) within my computer. So I uninstalled FSX via the Control Panel/Add and Rermove Programs. Shut down and restarted my computer, and reinstalled FSX Standard successfully until I tried to activate it. I get a message saying it can't be activated (standard message). I go through this process again using ANOTHER set of FSX discs (I have two legitimate copies), same thing! This would seem to indicate that the software discs are not the problem, but maybe something computer related. OK, I also have a copy of FSX Deluxe (legitimate), so I uninstall FSX Standard again and install FSX Deluxe . . . which loads successfully and activates successfully! However, it won't start. When I click on the FSX icon, it will bring up the Splash Screen for about five seconds and then it simply goes out. I have perused the forum and Google for a couple of days looking for similar entries to my problem, and while I've found lots of stuff and lots of potential solutions, nothing I've tried so far has worked.

So . . . am I looking at a bad HD (already run CheckDisc utility, no apparent problems), registry problems (already tried the FSX Registry fixer, no joy) or what? Anyone have any ideas? I'm about at the end of my rope! Thanks in advance for any help out there, I appreciate it!


2.8 Ghz chip; 2 Gbs RAM; 650 watt power supply (Brand New); XP 32 bit OS, 2 internal HDs, C:\ (80Gbs running OS only), D:\ (1 TB running FSX and some programs)

Link to comment
Share on other sites

I thought maybe that was it too. So I downloaded the "licensing something something file" (MSKB928080.exe) and ran it. While it did seem to actually do what it was supposed to do, the result was the same when I again tried to start FSX, splash screen for 5 seconds, then gone and nothing.

Come to think of it, when should I have run the MSKB928080.exe file? Sometime during the installation and/or activation process? FSX Standard did install and activate without any problem (that I knew of at the time), and it never gave me any kind of message about a licensing problem.

Link to comment
Share on other sites

If you see the splash screen the program runs.

It just crashes shortly after.

The reason for crashing (the faulting module) can be found in the error logs.

read the first "Sticky" (top of the fsx forum) on how to find that info.

(It's somewhere in "Start" - "Control Panel" - "System and security" - "Error logs").

Link to comment
Share on other sites

Agree with above. The Event Viewer is very helpful.


Make sure you are starting clean with no previous "standard" files and no user files associated with FSX. Searches here for removing FSX might help you.



2 carrot salad, 10.41 liter bucket, electric doorbell, 17 inch fan, 12X14, 85 Dbm
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...