Jump to content

FSX Glitch: All white textures (steam)


Recommended Posts

I turned on Direct X to see if it would help me get more frames. It turned all the textures white (this is known). But when I turned Direct X off everything was still white. I need to note that it is not the aircraft. The aircraft and runways and some other object have textures, but the ground is all white. I tried everything, even fully unistalling the game and buying it again. Nothing works.
Link to comment
Share on other sites

Sounds more like some textures got a permanent change. Try this:


To verify you game files please do the following:


1. Load the Steam platform and log into your account

2. Click the Library tab in the menu at the top of the screen

3. Click the List View from the view options on the top right of the screen

4. Right click on Microsoft Flight Simulator X: Steam Edition to bring up a popup menu

5. Click on Properties from the popup menu to bring up another popup box

6. Click on Local files from the popup box menu

7. Click on Verify integrity of game cache from the Local file options

8. Wait for the progress bar to finish verifying your files. Additional files may download

9. Restart Steam

10. Restart Microsoft Flight Simulator X: Steam Edition

Still thinking about a new flightsim only computer!  ✈️

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...