Jump to content

Can't fly, freeze at loading complete


Recommended Posts

I recently change settings of DX10 Scenery Fixer VC shadows and try to play, working fine. I have several addons but i never had problems with. Then when I start the game, in the free flight mode, I can't see the aircraft in the box, it's just a black screen, if I try to select one and look in details, same thing. If I click on Fly now, the loading starts at nearly 80% and stop a 100%, where it freezes. The loading is very short and skip all the terrain loading, etc.


I have to close the game because FSX is not responding. I tried to delete the logbook, restart my computer but it still don't work. I think it comes from a Rain40.fx, DX10 think it is a shader, I delete it, and there is the problem. Before, it was working, after I deleted, it's not working.

I don't want to reinstall all the addons I have (at least 20 !). I'm using the boxed version of FSX on Windows 10.

Is there a solution ?

Link to comment
Share on other sites

Just a shot in the dark (based on my experience in FS9). When FSX loads go into the settings and turn off anti-aliasing and anisotropic filtering. Restart FSX and see if you can start a flight then. If so, you should be able to set the filters back to how you had them before. If that didn't help, sorry: I hope someone else comes up with a solution for you!


Bon courage!

Link to comment
Share on other sites

Thank you for your answer.

I startéd FSX, Stiller black screen on the aircraft, sent to settings, diable anti-aliasing, anisotropic filtre and without gong to free fligh, close the game. I restart the game but samedi issue, shirt loading and no aircraft before flight.

I tried several times but it's not working :(

Link to comment
Share on other sites

One more possibility. Find and delete (or better move - not copy - to the desktop) your FSX.cfg file. Then start FSX - a new cfg file will be built. Does that help? (The file is normally in C:\Users\your user name\AppData\Roaming\Microsoft\FSX. You may need to show hidden folders to see the AppData folder.


If not, back up your FSX scenery.cfg file - not the one in the FSX folder or at the above location, but the other one installed here:


C:\Users\All Users\Microsoft\FSX


- and in Notepad (or whatever) delete all the entries which are not default FSX entries - that is from [Area.122] and higher in my file - the last default FSX one is probably [Area.121] "Edwards_AFB". Does FSX run then? If so, add the third-party entries back in batches (copy and paste from the backup) - you may find the one which is causing the problem.



Link to comment
Share on other sites

@ XeLight - Some things to try.............


You state that you have deleted the logbook in an attempt to solve the issue - other files that may become corrupted and cause problems are the files associated with the 'last' flight and updated/saved when you close the sim down. These are the .FLT, .FSSAVE and .WX files that are located in the same location as the logbook file (C:\PrgramData\Microsoft\FSX). Look specifically for files that are simply named Previous Flight, as this is the default name the file is given when you don't actually save a flight with a given name. You may have other files with the file extensions indicated, especially if you regularly save a flight with a given name. In addition so addons will also add files with the same extensions especially if training flights are provided as part of the package. So if no file named Previous is present look any files that you may have created yourself. Simply either delete the files OR move (using cut and paste) to a location outside of the FSX folder


If you are using Full Screen mode change the setting to start in Windowed mode.


If that doesn't work try disabling DX10 Preview and see what happens. If it works fine with DX10 Preview disabled then the issue must lie with the DX10 Scenery Fixer installation itself. Try uninstalling it, reboot, retest FSX to make sure its functioning OK and then re-install the fixer app and then test FSX again.


WRT to Martin's suggestion - if you have the Acceleration version installed then the last default scenery entry number will be Area.121 Edwards AFB but if you only have the standard version then the last entry will be Area.115 Addon Scenery........




Link to comment
Share on other sites

Hi everyone,

I solved my issue, I download the default fx files because DX10 do'nt work without some files (same for DX9). So I just replaced everything in my ShadersHLSL folder and everything is working now !

Thank you for help as well, have a great christmas !

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...