Jump to content

FSX addon scenery textures not showing up


Recommended Posts

Did any of these payware addons have a README file or manual with suggestions of where your sliders need to be to give the best results? The one I can think of, off hand, would be the Scenery Complexity slider maxed out.

Still thinking about a new flightsim only computer!  ✈️

Link to comment
Share on other sites

Well increasing didn't work either


How about your AutoGen slider? Have you tried increasing that one too? My last suggestion would be to go to each of the payware sites, register for their forums and ask for help there!

Still thinking about a new flightsim only computer!  ✈️

Link to comment
Share on other sites

What are the specs of your PC?


Also, has this happened from since day 1 that the products were installed or have they functioned correctly in the past?


In my experience such problems, especially if they affect multiple 'heavy resource' payware products, are usually associated with a memory problem - more specifically the lack of available memory resources to allow the scenery to load correctly.


As these product tend to be very detailed they require more memory to run. It must be remembered that FSX, being a 32-bit program, can only use a total of 4Gb of memory. If you have, say, only 4Gb of RAM with a 32-bit OS (which according to MS needs a min of 1Gb of RAM to run), FSX may only be getting about 2.5 to 3Gb at best. With a 64-bit OS with 4Gb RAM it will actually be worse as the 64-bit OS requires a min 2Gb of memory to run.


Somethings you can try are:


One of the other sliders that will have a big impact on how scenery is drawn is the Level of Detail Radius.


However, I would suggest changing all the sliders on the Scenery tab down to a middle setting and also turn off ground shadows.


On the Graphics tab turn down the Filtering setting and turn of Anti-Aliasing if selected. Also check your Target Frame Rate setting - if you have it to high your the sim will constantly attempting to achieve what you have set taking up valuable CPU resources so set it at a fixed lower rate - 30 FPS for example


Another possibility is that your are using DX10 preview mode. Some of the products may not support DX10 so try switching it off if you have it selected - its set on the Graphics Tab


This should give you a 'baseline' configuration to work from. Test in this config and if it works fine make small adjustments and test again and so on until you start getting problems and then go back to the last good config settings.


Prior to testing, read the product manuals as they will give details of the minimum/suggested settings required to display correctly. Some may give tips on how to reduce the memory load (by recommending certain files that can be removed to educe the load whist sill maintaining good visuals etc)




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...