Jump to content

Saitek Devices


Recommended Posts

Hey Guys,


I've already owned the Saitek Yoke, Throttle Quadrant, and Rudder pedal, these have been working fine with my FSX. However, I recently bought a Multi, Radio, and FIP panel, I downloaded the Saitek drivers. The Saitek own panels tester interact fine with my panels, but when I run fsx it doesn't recognize them at all.

I use Win 7. I plugged the different USBs to different USB plugs. I've already reinstalled FSX, and Saitek drivers, but there is no change.


Is there anybody who knows the solution? Thanks for the help in advance.

Link to comment
Share on other sites



I use Saitek products; 4 Flight instrument Panels, a Saitek X-55 Rhino stick and throttle, the multipanel, switch panel and radio. I also use the Saitek drivers and run Win 7.

The fact that the test panels interact with the actual panels tells me that your drivers are working.


First I have to ask: Are you started the FSX plugin found in Start: All Programs: Saitek Pro Flight Panels: Launch the Flight Sim X plugin?


If not: Try launching the plug-in.


If you have launched the plug-in, then perhaps the following might help.


I use powered USB port hubs. perhaps that is the problem. not enough power to drive the panels.

What I would suggest is using one panel at a time, plug it into a powered USB port (usually the ones in the back of the computer) and start FSX to see if one works. If it does, exit FSX, plug in another one and try FSX again. Repeat.


If you cannot even get one to work try reinstalling the drivers.

I hope the helps. Good luck

Please report back.



Link to comment
Share on other sites

Dear Joe,


First of all, thanks for your quick reply, and help. Unfortunately I lost my fortune.


I followed all of your suggestion without any success.

When I click on saiflightsimX.exe it starts, I can see it in the Windows task manager.

My multi panel starts showing the ALT/VS, but nothing else. (It is a static screen).

After I open the Pro Flight Panels folder, I can see a Saipanels.exe, however, when I click on it, a pop-up says: It is unable to connect to FSUIPC. In fact, I only have the free fsuipc, not the paid one. Can it be a problem?


Furthermore, I don't think the energy-supply is the problem, because of the tester works perfectly, as well as, my multi panel always shows the ALT/VS screen.


Best, Kistupi



Link to comment
Share on other sites



Sorry that you had no luck.


Firstly having the free version of FSUIPC should not be the problem. I have had my Saitek devices for over a year and a half and only recently purchased the registered version.


Let me address the multi panel. You state that it is a static screen and only shows the ALT/VS. Forgive me for stating the obvious but I need to know that we are on the same page, The multipanel is an auto-pilot and on start up will only show the ALT/VS. Have you tried :

1. pushing the AP button to see if it lights up?


2. turning the knob to any other position such as HDG or CRS? The panel should display those letters in red just as the ALT/VS?


3. You don't mention the FIP. Does that display any Gauge such as the ASI, Turn Indicator etc.?


I notice in you screenies that you are in Windows Explorer. That is NOT where you should be to start the plugin. Follow this procedure step by step and see what happens.


1. Start FSX.


2. When FSX loads to the first screen (where you can choose aircraft, weather, starting point etc.) then


3. Go to the lower left of the computer screen and Click the ROUND WINDOWS logo to bring up the start menu


4. In this window you will see, right above the search programs and files box, ALL PROGRAMS. Click on all programs


5. You will then see a list of folders. Scroll down to Saitek Pro Flight Panels folder and click to open


6. Then you will see a list such as Launch the FS2004 Plugin, Launch the FSX Plugin, Multipanel Test Page. Click on Launch FSX Plugin.


Since you had started FSX first, then started the plugin, everything should be able to connect to and through FSUIPC.


By the way, my plugins start automatically but I can't really remember how I accomplished that.


Any way, you seem only concerned about the multipanel. Do the radio and FIP work OK?


Try the above steps exactly and let me know how it went, If it did, GREAT! If not we'll go again and figure something out.


Best wishes, Joe

Link to comment
Share on other sites



I use powered USB port hubs. perhaps that is the problem. not enough power to drive the panels.




+1 on the use of powered USB port connectors! Considering they are so cheap, I can't imagine using multiple USB plugin devices not using at least one powered port connector! A powered port may help this specific issue or it may not. However it will certainly cut the voltage draw down on your motherboard rails.


Remember lower voltage requires a higher amperage draw to produce the same number of watts needed to run your board and every device that operates on or is powered by it as if the voltage was higher! The higher your amperage draw the hotter all your equipment gets. The hotter any device is, the sooner it will fail!


To my mind, regardless of other issues or lack thereof, powered USB port connectors provide cheap device replacement insurance!! :cool::cool:

Being an old chopper guy I usually fly low and slow.
Link to comment
Share on other sites

I've been struggling with Saitek-panels and -drivers also, but after reading about SpadNext I decided to forget Saitekdrivers and go for SpadNext. Worked fine for me....!!

IMHO they are way better then Saitekdrivers.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...