Jump to content

Trouble with FSX on new PC


Recommended Posts

Hi, I've been into FSX for about 2 years now. I had it installed, boxed version, on a PC running Windows 7 Home Premium and upgraded my system. Am now running a Lenovo H50 with a AMD A10-7800 Radeon R7 with Windows 10. I installed FSX fine and then installed the Acceleration upgrade disk. The sim runs great, graphics are great, everything is good.....for 30 minutes. I get a error saying i need to activate the program because my 30 minute time trial has ended. I activated the original FSX disk but was never offered an opportunity to enter the activation code for the Acceleration upgrade disk. What do I have to do to enjoy the sim again for longer than 30 minutes?
Link to comment
Share on other sites

So what happens if you restart the sim again? Does it ask you for the activation code or still expires after 30 minutes?
Link to comment
Share on other sites

  • 2 months later...

There are several fixes around. They may be old, but this is what I just did.

Win 10 x64

C: is an SSD - system and progs only

X: is an HDD with all the documents, caches & user account folders

FSX Deluxe (FSX)

FSX Acceleration (FSXA)

ASUS Sabertooth FX 2.0


1x R9 380 (2GB)

AMD FX9590


Downloads for SP1 and SP2 were from https://www.microsoft.com/Products/Games/FSInsider/downloads/Pages/default.aspx

Instructions for B were from Brianstabinger's post @ https://www.flightsim.com/vbfs/showthread.php?253089-quot-Product-Activation-Error-1-80004005-quot-What&p=1703563#post1703563


In A, I had a saved copy from 2012.

If you cannot find a copy, u can dload from https://flyawaysimulation.com/downloads/files/18934/fsx-resetsldlexe/ (a bit cheeky, I know, but I could not find one in the FlightSim library !)


In B, I followed the instructions ONLY AS FAR as opening the tree to the right place.

Once there, I simply changed the p and m to uppercase P and M (as you can see in later posts in that thread)


A Run resetsldl.exe prog via CMD to reset licences (using MSKB928080.exe)

B Set registration entry partmgr -> PartMgr


1.install FSX - make sure -> "options" and UNTICK start game

2.install SP1 & SP2

3.start & activate


5.run FSXA installer

6.remove SP2

7.run FSXA installer again

8.start FSX

9.activation wizard started


I know I could have perhaps left out SP2 before going straight to FSXA, but I installed it just in case.

I could also probably have not installed SP1, but as I had already tried that and it failed, I felt there was perhaps something in there that might help FSXA sort it's little head out.


I also had to telephone activate FSX on the first install, went without a hitch, and if you do have to (because of "installed too many times"), make sure you write the numbers down as you can use them again with the same DVD key on reinstall.


I do not know which, or how many, of those worked - but the end result is mine is working now.

I was determined to keep going until I suceeded because the steam version is a rip-off with real trees @ £20, or free from in here.


Good luck!



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...