Jump to content

Stutter interruption or sound bug? Win 10

Recommended Posts



Since upgrading to Windows 10 yesterday my FSX is getting some sort of interruption which causes a momentary buzz to come over the speakers. I hear it even when the music is playing on the opening screen but also during flight. The buzz lasts for about a quarter of a second and is intermittent , not regular but often.


I am not sure if I am imagining it but it seems to coincide with the odd screen stutter.


I have tried various aircraft and it happens on all of them. I have checked my sound drivers and all are up to date.


I am running FSX deluxe dvd edition on a 3.4 ghz PC with an nvidia gtx660ti. Everything was fine under Windows 7.


Has anyone else experienced this problem?


Thanks for looking


Link to comment
Share on other sites

I had that recent;ly.

normally I have speakers, attached with 3.5mm jack, and a USB plug for power.

I had just added my USB dongle for the headset, wireless, which then switches Windows to the headset as default device automatically.

I put on the headset, and the sound was doing what you described.

After unplugging, the speakers did it too!


Tried a few things in sound menu, nothing.

Tried unplugging the audio devices one at a time. nothing.


Then thought. that helped.

-Buzz on speakers/headset.

-means, current where it shouldn't be.

-both are usb connected, or at least that section of the mainboard.

-let's disconnect all usb devices, you never know...


and indeed, all usb devices disconnected, then replug keyboard/mouse and audio only.



-Check all other usb devices and cables visually.

-And, as I thought, first thing I checked was the culprit... Printer was acting up again.

My printer regularly throws a fit and reports an error (yellow flashing exclamationmark in the small display on the printer itself.)


-Pulled its power cord and replugged it. Some grunting noises. Fixed.

-reconnected all usb cables.

audio still OK.

Link to comment
Share on other sites

Wow. That was quick and you have cured it straight away. I had utilised a USB port for my yoke which was dodgy. Switched it to another and hey presto. Thanks so much. I was ready to blame windows 10 for that!


Happy bunny again.

Thanks again for replying, ah the power of communication [emoji4]





Sent from my SM-A300FU using Tapatalk

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...