Jump to content

Pro Flight Yoke and X-52 issue with Windows 10


Recommended Posts

Please help.....


I've searched and searched having yet to find someone with a situation similar to mine. The first of November after a fresh install of Windows 10, I re-installed FSX Steam and the drivers for both my Pro-Flight Yoke and X-52 (non pro). I changed some assignments and programmed a couple of things with the profiler software....all was well. Then I proceed to get busy with Thanksgiving and Christmas so it sets for a while. I return a few days ago to try a quick flight and upon plugging in my yoke it stays lit for a few seconds (around 10 or so) then promptly goes dark and stays that way. The X-52 does the same thing. The PC gives me the tone when I plug in the device so it recognizes a connection, but when I go into device manager it simply lists it as an "unknown" device. Windows fails to load the drivers and says "The driver installation file for this device is missing a necessary entry. This may be because the INF was written for Windows 95 or later. Contact your hardware vendor." I go to the MadCatz/Saitek site and download drivers again and the driver installation hangs at the point where it instructs me to plug in the device. After removing all Saitek software and trying to reinstall drivers several times I finally gave up. I've tried every usb port on my machine with the same result. I know the ports are good because other devices plugged into them work fine including my CH pedals.


At this point I'm at a loss. Thanks for reading.

ASUS P8P67 Deluxe*i7-2600k 4.4GHz*XFX Radeon HD 6950 2GB 840MHz*CORSAIR HX 750w*CORSAIR Vengance 8GB (2 x 4GB) DDR3 1600

Caviar Black 750GB*CORSAIR Hydro H70 Cooler*Windows 7 64bit Home

Link to comment
Share on other sites

  • 8 months later...


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...