Jump to content

Cannot Get F4 Phantom Download To Work

Allen Craig

Recommended Posts

Giving it the ol college try right now!


Didn't work for me as some Iris freeware do. I get an immediate crash when I hit "Fly Now". After deleting the aircraft I tried several others hitting the L key with no adverse actions.

Still thinking about a new flightsim only computer!  ✈️

Link to comment
Share on other sites

I have it installed. I only saved the Blue Angels versions. I did not install any of the Effects or Textures since I heard about the potential "L" problem. It works fine. I tried several others too and had no "L" problem. It probably has something to do with the Effects and Textures. I am going to look into them next. Bob.


Edit: I have all the Effects installed and no problems yet with the "L" key in other planes. Next comes the Effects Textures.


Edit1: All Effects Textures are installed. I had most of them. No problems with the "L" key in other planes.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...