Results 1 to 7 of 7

Thread: SBuilder For FS9

  1. Default SBuilder For FS9

    Cannot get SBuilder for FS9 to work get
    "Run-time Error 339 Component 'COMDLG32.OCX' or one of its dependencies not correctly registered: a file is messing or invalid"
    I have checked forum for similar errors, none found or I didn't go far enough.
    Computer has been completely restored.
    Everything else seems to be working fine.
    'COMDLG32.OCX' and 'TABCTL32.OCX' are in the "System32 folder"

    I have tried FSDeveloper Forum, as of now I haven't received a answer.

  2. #2
    Join Date
    Mar 2005
    Location
    40 miles north KMSP
    Posts
    2,542

    Default

    You need to run a registration utility as regsrv32 under the command prompt. (This is not a product registration but a Win thing.) Please see this thread. It has a different error message but see if it helps.
    http://forum.avsim.net/topic/265834-...gistered-dlls/

    Read a bit into the thread.

    Some users in Win 7 put those in multiple folders which helped.
    KMSP - Minnesota: Land of 10,000 Puddles
    Support Team

  3. #3
    Join Date
    Mar 2005
    Location
    Bonners Ferry, Idaho, USA
    Posts
    2,646
    Blog Entries
    5

    Default

    I went through this myself a few months ago, in about 20 minutes I had the problem solved and was doing whatever it was I needed SBuilder for so I didn't attach a lot of importance to remembering what I did to fix it. I have a vague recollection of what I did though, here goes:

    It seems SBuilder first complained about COMDLG32.OCX. I found a copy of that on the net, and if I recall correctly it needed to be in the "SysWOW64" folder rather than system32. You have to either register the .ocx with a dos command or IIRC rebooting the computer will register it also. The site I got the files from was an MS sponsored site and I remember the .ocx files came with some additional file that took care of registering when you double-clicked it. It wasn't a batch file but something similar. I believe I found that site by googling "Component 'COMDLG32.OCX' or one of its dependencies not correctly registered", but I couldn't tell you the name of it or the address now.

    After that it seems SBuilder complained about yet another missing file, I can't remember the name, but I found a copy of that one too from the same site and dropped it into SysWOW64. Eventually I must have given it everything it needed because I can start SBuilder without problems at this moment.

    I would try copying or moving COMDLG32.OCX into the SysWOW64 folder, rebooting the computer, and then try starting SBuilder again. I do not have a copy of COMDLG32.OCX in my system32 folder incidentally, only the SysWOW64 folder, so providing you're using a 64 bit operating system I'm fairly confident that that's where it needs to be.

    Jim



    i7 2600K @ 4.4 gHz | GA-Z68XP-UD3-iSSD | GTX770/4Gb | 8 Gb DDR3 @ 1866 | Crucial M4 256Gb SSD (x2) | 1Tb WD Caviar 6Gb/sec | 27" ASUS Monitor | W7 Pro 64

  4. Default

    Mr. Robinson your memory was spot on. Thank You.

    I had downloaded the, "comdlg32.ocx" file before, I cut and pasted the file in the,"SysWOW64" folder. I started "SBuilder" without rebooting, and now everything seems to be working the way it should.


    Spoke to soon, now getting runtine error 339 when trying to open new airfield.
    Last edited by wbunnell; 01-16-2013 at 10:13 PM.

  5. #5

    Default

    Just my two cents....I have the COMDLG32.OCX file located in System 32. Been using SBuilder for some time now with no problems.
    Allan

  6. Default

    Apparently both the "comdlg32.ocx" and the "TABCTL32.OCX" files, have to be in the "SysWOW64", folder. After a night's sleep I put the "TABCTL32.OCX", file in the SysWOE64", folder.
    SBuilder is working right now.

  7. #7
    Join Date
    Mar 2005
    Location
    Bonners Ferry, Idaho, USA
    Posts
    2,646
    Blog Entries
    5

    Default

    Well I'm glad to hear you got it sorted one way or another.

    Jim



    i7 2600K @ 4.4 gHz | GA-Z68XP-UD3-iSSD | GTX770/4Gb | 8 Gb DDR3 @ 1866 | Crucial M4 256Gb SSD (x2) | 1Tb WD Caviar 6Gb/sec | 27" ASUS Monitor | W7 Pro 64

Similar Threads

  1. SBuilder new library for FS9
    By dva51 in forum Scenery Design
    Replies: 21
    Last Post: 03-16-2014, 07:20 PM
  2. Replies: 10
    Last Post: 11-09-2011, 03:06 AM
  3. Looking for a tutorial on SBuilder Terrain mesh
    By thindog in forum Scenery Design
    Replies: 2
    Last Post: 05-15-2010, 12:57 AM
  4. FS9 SBuilder Night Photos Glitch
    By cep in forum Scenery Design
    Replies: 0
    Last Post: 04-09-2009, 11:55 AM
  5. Sbuilder Q
    By industries in forum Scenery Design
    Replies: 3
    Last Post: 10-19-2007, 01:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •