Results 1 to 2 of 2

Thread: Saitek X52 throttle works, joystick doesn't

  1. Default Saitek X52 throttle works, joystick doesn't

    when I plug the throttle and the joystick together with the cable and then plug in with the throttle's USB cable, the lights on the throttle light up and are steady. The joystick's lights flash. In control panel, the throttle works and the joystick is not recognized. Is the cable between the throttle and the joy bad? The whole system worked before I moved and hasn't worked since.

  2. Default

    I've actually bumped into this before. If I unplug everything and then reconnect everything, it seems to start working just fine.

Similar Threads

  1. Saitek X52 Joystick
    By debonis in forum PC Hardware, Video And Audio Help
    Replies: 4
    Last Post: 10-12-2010, 08:34 AM
  2. Replies: 5
    Last Post: 01-25-2010, 04:33 PM
  3. Saitek x52 throttle reversed
    By Johntheplumber in forum FSX
    Replies: 2
    Last Post: 11-16-2009, 06:12 PM
  4. FSX and Saitek x52 joystick
    By flyger in forum FSX
    Replies: 4
    Last Post: 11-04-2009, 07:45 AM
  5. Saitek X52 Throttle advancing when at idle.
    By potbelly in forum FS2004
    Replies: 5
    Last Post: 07-12-2006, 02:51 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •