Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: REX Overdrive on FSX question

  1. #1
    Join Date
    Mar 2005
    Location
    Cleveland, Ohio, U.S.A..
    Posts
    722

    Default REX Overdrive on FSX question

    I would have just posted this on the REX forum but I see they look like they've got their hands full with taking care of installation questions etc..

    After loading the Overdrive free upgrade the tropical shorelines are really amazing.

    However, I noticed I no longer get the second window that comes up with the weather map when I start it. Is this the same thing for everyone or might I have a problem?

    Mitch
    Problems today exist because the people who work for a living are out numbered by those who vote for a living!
    Wind7 64-240 GB SSD-4GB RAM-3.33 OC'd to 3.99ghz Int.Duo E8600-GTX650Ti Boost OC-TH2G-Saitek Yoke, -CH pedals-GFTQ6 throt.

  2. Default

    Isn't there a 2nd file / shortcut for starting up that weather map?

    I have two shortcuts on my desktop at least.

  3. #3
    Join Date
    Mar 2005
    Location
    Cleveland, Ohio, U.S.A..
    Posts
    722

    Default

    I only have one. I used to open the icon on the desktop then click on the "fly now" option which used to shrink down to the bottom taskbar and then another window would open with WA (Weather Avoidance) and then it would show the weather map for the area I was in. Now the "fly now" button just shrinks down into the task bar with nothing else opening up. So now I really don't know if I'm getting the real-time weather or not.

    Mitch
    Problems today exist because the people who work for a living are out numbered by those who vote for a living!
    Wind7 64-240 GB SSD-4GB RAM-3.33 OC'd to 3.99ghz Int.Duo E8600-GTX650Ti Boost OC-TH2G-Saitek Yoke, -CH pedals-GFTQ6 throt.

  4. #4
    Join Date
    Mar 2005
    Location
    La Porte, Indiana, USA.
    Posts
    63

    Default

    I installed the Overdrive files, open REX, click on the "fly now" and the weather avoidance opens up just as before the installation. I did notice that a couple of the options that I originally clicked on were changed. You might go there to check what you want REX to do when you open it.

  5. #5
    Join Date
    Mar 2005
    Location
    Cleveland, Ohio, U.S.A..
    Posts
    722

    Default

    Hmmmmm, looks like I'll need to get with them at REX to figure out what I did.

    Thanks for the reply.
    Mitch
    Problems today exist because the people who work for a living are out numbered by those who vote for a living!
    Wind7 64-240 GB SSD-4GB RAM-3.33 OC'd to 3.99ghz Int.Duo E8600-GTX650Ti Boost OC-TH2G-Saitek Yoke, -CH pedals-GFTQ6 throt.

  6. Default

    the waasys application of OverDrive is different compared to the previous REX 2.0 one. As consequence, when you start FSX the first time you should get a message asking whether you trust it or not. Did you get that when you run FSX after the installation of OverDrive?

    Also, the waasys will start side-by-side with FSX only if you selected that option in the REX main application. I suggest you check there first to see whether it is enabled (if not, enable it).

    If you believe you have somehow messed up things, edit FSX.cfg with notepad and look for a line (should be near the end) with allow the rex weather engine to run and simply delete it. FSX will ask again the next times it starts.

    Paolo

  7. #7
    Join Date
    Mar 2005
    Location
    Cleveland, Ohio, U.S.A..
    Posts
    722

    Default

    Paolo, I don't think I got the message asking if I trusted it or not.

    I don't see an option anywhere to load the waasys. I've attached a jpg of the configuration settings I have. I did notice that if I go into the Weather tab and OK the realtime weather that I get into a section that does have the waasys in it. I can download the airports information here and the map does pop that I was used to seeing automatically.

    I'll wait to hear back before I try to edit the cfg file.

    Thanks,
    MitchName:  Config OD.jpg
Views: 2946
Size:  126.6 KB
    Problems today exist because the people who work for a living are out numbered by those who vote for a living!
    Wind7 64-240 GB SSD-4GB RAM-3.33 OC'd to 3.99ghz Int.Duo E8600-GTX650Ti Boost OC-TH2G-Saitek Yoke, -CH pedals-GFTQ6 throt.

  8. Default

    According to that screenshot, the weather engine of REX should start when FSX starts ("Enable REX Weather Engine startup with FSX" box is ticked).

    If you do not see the REX weather window appearing when you start FSX, then there is something wrong.

    a) Easy way to try to fix it (however, I am not 100% sure it will work, there may be something wrong in the installation of OverDrive in your pc): untick that option, save the configuration, tick that option, save the configuration again, close REX and then start FSX.

    b) Hard way to fix it: open with notepad the file exe.xml which is located here:

    C:\Users\<your user name>\AppData\Roaming\Microsoft\FSX

    and check whether you have this group of lines:

    "
    <Launch.Addon>
    <Name>Real Environment Xtreme - Weather Engine 2</Name>
    <Path>D:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\REX\rexwxengine2.exe</Path>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    </Launch.Addon>
    "

    Please note that the <Path>... statement which points to the weather engine is dependent on where did you install REX 2.0 on your pc. This is the right path for my installation only.

    If that group of lines is missing, you need to add them, making sure you know where you installed REX 2.0. Make a backup of that file just in case before editing it.

    After a) or b) start FSX and check whether you see the REX 2.0 weather window. Eventually FSX will ask the permission to run it and store your approval in fsx.cfg. Try a) first since it is simpler.

    Paolo

  9. #9
    Join Date
    Mar 2005
    Location
    Cleveland, Ohio, U.S.A..
    Posts
    722

    Default

    OK, this will blow your mind.

    When I unchecked "Enable REX Weather Engine startup with FSX", it started working. I rebooted and got the same result. I can tell the cloud formations are not what I was getting previous.

    I guess I'll leave it at this unless something happens to it.

    When you are flying in FSX, do you get any text running across the top of the page saying REX is gradually loading the weather information? If so, I don't get that anymore either.

    Maybe I should do a complete re-install of REX.

    Mitch
    Problems today exist because the people who work for a living are out numbered by those who vote for a living!
    Wind7 64-240 GB SSD-4GB RAM-3.33 OC'd to 3.99ghz Int.Duo E8600-GTX650Ti Boost OC-TH2G-Saitek Yoke, -CH pedals-GFTQ6 throt.

  10. Default

    You should get the weather window of REX 2.0 AND from time to time the message on top (red text on green) saying "Rex is loading..." "REX has finished ..."

    There is something strange. Did you patched REX 2.0 adding the latest service pack before installing Overdrive, as explained in the REX support forum?

    You can check via Task Manager whether the application mentioned in exe.xml is running or not. It is responsible for the weather changes and the weather map.

    Paolo

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •