Results 1 to 4 of 4

Thread: D-Link Router and Multiplayer

  1. #1

    Default D-Link Router and Multiplayer

    I'm having a problem connecting to any multiplayer FS2004 game through my D-Link DI-524 router. I have forwarded/opened the nessesary ports in the setup software for the router, following D-Links instructions. At best I have been able to connect for about 10 sec before the server rejects, or it simply freezez the screen. I realize a simple soluton is to just bypass the router, which works and I have done. As I have no connectivity issues with anything else through the router and I can connect up if i bypass it, then I can only conclude it is a setup problem. D-Link has been helpful but no solutions yet.

    Anyone out there running a wireless D-Link router that can connect to a multi-player FS2004 game?

    Any help would be appriciated.

    Gary



  2. #2
    Join Date
    Mar 2005
    Location
    Virginia Beach, VA USA.
    Posts
    3,113

    Default RE: D-Link Router and Multiplayer

    Hey Gary,

    Have a look here http://www.PortForward.com . I'm behind a router as well(linksys). You might find something there......sometimes a simple reset works. Go back to default settings, then just reinstate what you know will work. After a long battle with mine it seemms as though it had actually done (finally) what was needed to fix the problem, but the "left-overs" of previous attempts were conflicting the fix. This stuff is a real pain in the neck to all but the pros or the real lucky, of which I'm neither. Good luck

    Best,

    Austin
    salt_air

  3. #3

    Default RE: D-Link Router and Multiplayer

    Hey Gary,
    Austin is definately correct about the reboot. I know it's a pain but I would suggest that everytime you make a configuration change on your router you reboot it. Although some changes are supposed to be dynamic, not all changes are and a reboot is often necessary.
    Try this link: https://grc.com/x/ne.dll?bh0bkyd2
    It is great to test how secure your PC is but you can also see what ports are open once you have forwarded them.

    Here's the exact article copied from FSHost website, may be of use to you, if not just to check that you have ALL the ports necessary, open.The article is based around running your own FSHost server but you should be able to gain the knowledge needed to connect to a remote FSHost server by reading it.


    If you're running FSHost from behind a firewall or router, you'll need to configure it so that it allows certain ports to pass through to the server machine.
    Ports required for an FS2002 session:
    TCP port 47624
    UDP ports 2300 to 2400 (the entire range)
    Ports required for an FS2004 session:
    The ports required for FS2004 depend on your configuration:
    If you're running one copy of FSHost and the "2004 Host Port" (on the Options / Session window) is set to the default UDP port 23456, then you only need to forward UDP port 23456 to the machine running FSHost. This is because the other players connecting will most likely have FS2004 set to use 23456 also, because it's the default in that program as well. (See the section Why can't other people find my FS2004 session? on the FAQ page for more info about how to change the port in FS2004.)
    If you're running one copy of FSHost and the "2004 Host Port" is not set to the default UDP port 23456, then you need to forward the port you're using, as well as the "alternate DirectPlay ports", which are UDP port 6073 and the range of UDP ports from 2302 to 2400. Most users will be able to find your session without changing their FS2004, but some will have to change it to be the same as the port you're using because of problems they'll have with connecting on 6073 and 2302-2400.
    If you're running more than one copy of FSHost, each needs to be on a different "2004 Host Port" (23456, 23457, 23458, etc.). You need to forward the ports you're using, as well as the "alternate DirectPlay ports", which are UDP port 6073 and the range of UDP ports from 2302 to 2400. Most users will be able to find your session without changing their FS2004, but some will have to change it to be the same as the port being used by the session they want to connect to, because of problems they'll have with connecting on 6073 and 2302-2400.
    NOTE: Remember that if you're connecting FS2004 to your own FSHost and they're both on the same machine, you need to change FS2004 to be on a different port. (See the section Why can't I find my own FS2004 session? on the FAQ page for more info.)
    Ports required for Remote Access (web interface) and FSHostSpy:
    TCP port 80

    NOTE: this should be set to whatever port you have set on the Options / Remote Access window in FSHost. Sometimes if you have a problem accessing FSHost with a web browser, or with FSHostSpy, you can change it to port 81 to fix the problem. If you do this, be sure to forward that port in your router instead of the default port 80.
    NOTE: If a player connecting to your session is using a router, that player will also need to configure it to forward the same ports you're forwarding. For example, if you're forwarding UDP 23456 to your FSHost machine, he'll need to do the same and forward the same port from his router to his FS machine. If he doesn't, then other players connecting to the session after he does may get the error, "Unable to connect to all players", because they're not able to connect to him properly. See the section What is the error "Unable to connect to all players"? on the FAQ page for more info.
    Unfortunately each firewall or router is different, so you'll have to read the instructions for yours to figure out how to open ports. Once you figure it out though, let me know and I'll add it to this information to help other players.
    Windows XP Firewall
    If you're using the firewall in Windows XP, you'll need to disable it for people to connect to your game. To do that, go to Start / Settings / Control Panel / Network Connections. Then right-click on your internet connection, and select Properties. Change to the Advanced tab, and clear the first checkbox for "Internet Connection Firewall" . Unfortunately there doesn't seem to be a way to setup XP's firewall to open a range of ports, so it's better to just disable it completely.
    Note: If you're only running a 2004 session in FSHost, you can use the XP firewall by adding a new entry for UDP port 23456 (both "internal" and "external"). See the notes above about the required ports.

    Best
    Geoff (cs33@flightsim.com)

  4. #4
    Join Date
    Mar 2005
    Location
    Sacramento, CA, USA.
    Posts
    103

    Default RE: D-Link Router and Multiplayer

    I have a DI-604 and was having the same sort of trouble recently. I downloaded the latest firmware update, reset all my port forwarding and it worked like a champ. I'm gonna jump on the bandwagon with Austin & Capn_Sonic about rebooting the router. Enough said.

    Mark

Similar Threads

  1. Router and Multiplayer
    By Piper_Pilot in forum PC Hardware, Video And Audio Help
    Replies: 9
    Last Post: 08-17-2005, 01:45 AM
  2. Multiplayer through a router
    By capherc in forum FS2004
    Replies: 1
    Last Post: 11-07-2003, 01:29 PM
  3. Replies: 0
    Last Post: 02-12-2003, 10:57 PM
  4. FSHost multiplayer and router
    By sdsim in forum FS2002
    Replies: 28
    Last Post: 01-03-2003, 09:35 PM
  5. MultiPlayer thru Router Ports
    By ronezra in forum FS2002
    Replies: 3
    Last Post: 08-25-2002, 12:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •